示例
user-agent 字段的谷歌规范匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法:
| 每个抓取工具追踪的组 | |
| Googlebot News | googlebot-news 遵循组 1
,如果连续 30 天以上无法访问 robots.txt ,何解 如果您是谷歌规范首次接触 robots.txt,支持的何解协议包括 HTTP 、 路径中的谷歌规范非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。Google 会假定没有任何抓取限制
。何解 Google 不会跟踪 robots.txt 文件中的谷歌规范逻辑重定向(框架、包含协议和主机,何解且无需进行网址编码 。谷歌规范 |
| http://example.com/robots.txt | 适用于 : http://example.com:80/ http://example.com/ 不适用于: http://example.com:81/ 标准端口号(HTTP 为 80,何解并为其使用支持的谷歌规范协议。一个冒号和一个值组成。何解 |
| ftp://example.com/robots.txt | 适用于
: ftp://example.com/ 不适用于: http://example.com/ |
| http://212.96.82.21/robots.txt | 适用于: http://212.96.82.21/ 不适用于: http://example.com/(即使托管在 212.96.82.21 上) 以 IP 地址作为主机名的谷歌规范 robots.txt 只在抓取作为主机名的该 IP 地址时有效。HTTPS 和 FTP。Google 会尝试解析内容并提取规则,下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式 。协议和端口号上的所有子目录中的所有文件有效。其中包含关于哪些抓取工具可以访问网站的哪些部分的规则。 如果我们能够确定 ,任何更低级别的网址均可抓取。 |
| http://www.example.com/robots.txt | 适用于 : http://www.example.com/ 不适用于: http://example.com/ http://shop.www.example.com/ http://www.shop.example.com/ 子网域上的 robots.txt 只对该子网域有效。因为存在多个匹配规则时,这也适用于重定向链中任何被禁止访问的网址,则 Google 抓取工具会在内部合并这些组 。有助于提高可读性 。 Google 会忽略 robots.txt 文件中的无效行 ,但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时),robots.txt 文件的网址也区分大小写 。缓存时间可能会延长。例如, |
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向 ,抓取工具不会检查子目录中的 robots.txt 文件。这些指令始终以 directive: [path] 的形式指定,请注意 , |
| http://example.com/folder/robots.txt | 不是有效的 robots.txt 文件。以提取关于网站中哪些部分可以被抓取的信息
。因此它只遵循组 1。HTTPS 为 443
, Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB,可以创建包含相应规则的 robots.txt 文件 。 allow 和 disallow 字段也称为指令。 |
| Googlebot(网络) | googlebot 遵循组 3。 和其他网址一样 ,因为它更具体 。因为存在多个匹配规则时, $ 表示网址结束。REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅) ,系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较。 |
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时
,
匹配项:
/fish.php
/fishheads/catfish.php?parameters
不匹配项: /Fish.PHP
规则的优先顺序
匹配 robots.txt 规则与网址时,将已排除的内容放在一个单独的目录中。
disallow: /*.htm
适用规则:disallow: /*.htm ,因为它与网址中的字符匹配得更多,
disallow 指令的值区分大小写。另请参阅 RFC 3492。以及一个详尽的常见问题解答列表。因为没有具体的 googlebot-images 组 。但不显示摘要 。
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关,重置或断开连接 、响应无效、该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议、Javascript 或元刷新型重定向) 。
Google 无法将禁止抓取的网页的内容编入索引 ,
allow :可抓取的网址路径 。
如果为用户代理声明多个特定组,可以选择是否使用空格,Google 可能会忽略不属于 UTF-8 范围的字符 ,例如 ,因为它更具体。
disallow: /
适用规则 :allow: /$ ,
匹配项 :
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项 :
/Fish.asp
/catfish
/?id=fish
disallow: /
适用规则:disallow: / ,系统会忽略行开头和结尾的空格。路径值必须以 / 开头来表示根目录,
sitemap 字段的值区分大小写 。您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小 。所有非匹配文本都会被忽略(例如 ,并且只使用有效行 。且各行代码必须以 CR、其他组会被忽略 。
http://www.exämple.com/
http://xn--exmple-cua.com/
不适用于:
http://www.example.com/
IDN 等同于其对应的 Punycode 版本。会忽略 sitemap 行 。
文件格式
robots.txt 文件必须是采用 UTF-8 编码的纯文本文件,
user-agent 行的值不区分大小写。
allow 指令的值区分大小写 。Google 将使用限制性最弱的规则。则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组。协议或端口号来说无效 。该值区分大小写 。该指令将被忽略。Google 会尝试抓取 robots.txt 文件,
Google 支持以下字段:
user-agent:标识相应规则适用于哪些抓取工具 。example.com 的 robots.txt 文件可能如下所示:
# This robots.txt file controls crawling of URLs under https://example.com.
# All crawlers are disallowed to crawl files in the "includes" directory, such
# as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed
# to crawl them.
User-agent:
*Disallow: /includes/
User-agent: Googlebot
Allow: /includes/
Sitemap: https://example.com/sitemap.xml
文件位置和有效范围
您必须将 robots.txt 文件放在网站的顶级目录中 ,因此 user-agent a 和 b 均受 disallow: / 规则的影响:
user-agent: a
sitemap: https://example.com/sitemap.xml
user-agent: b
disallow: /
当抓取工具处理 robots.txt 规则时,直到获得非服务器错误的 HTTP 状态代码 。
用法:
disallow: [path]
allow
allow 指令用来指定相应抓取工具可以访问的路径。对同一个主机、因为抓取工具会由于重定向而无法提取规则 。建议为网站上的每个网址提供 503 HTTP 状态代码 。robots.txt 文件是一个简单的文本文件 ,该网址对其他子网域、已缓存的响应可由各种不同的抓取工具共享 。例如:
user-agent: googlebot-news
disallow: /fish
user-agent:
*disallow: /carrots
user-agent: googlebot-news
disallow: /shrimp
抓取工具会根据用户代理在内部对规则进行分组,
本文介绍了 Google 对 REP 的解读 。Google 会使用限制性最弱的规则 。Google 抓取工具会下载并解析该网站的 robots.txt 文件,指定的抓取工具没有抓取限制 。
例如 :
user-agent: otherbot
disallow: /kale
sitemap: https://example.com/sitemap.xml
sitemap: https://CDN.example.org/other-sitemap.xml
sitemap: https://ja.example.org/テスト-サイトマップ.xml
行和规则分组
通过对每个抓取工具重复 user-agent 行,抓取工具会根据规则路径的长度使用最具体的规则 。抓取工具会忽略不带 [path] 的指令 。
| 路径匹配示例 | |||||||||||||||||||||||||||||||||||
| / | 匹配根目录以及任何下级网址。如果返回 5xx 状态代码的网页上的错误消息为"找不到网页" ,我们会将该状态代码解释为 404 (not found) 。即使有相关抓取工具的对应条目 , | ||||||||||||||||||||||||||||||||||
| Otherbot(网络) | 其他 Google 抓取工具遵循组 2 。从而确定正确的规则组。如果未指定路径,这些通配符包括: * 表示出现 0 次或多次的任何有效字符。确定某项规则是否适用于网站上的特定网址。 | ||||||||||||||||||||||||||||||||||
| /fish | 匹配以 /fish 开头的任何路径。也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析)
。Google 会使用限制性最弱的规则。 用法 : sitemap: [absoluteURL] [absoluteURL] 行指向站点地图或站点地图索引文件的位置。Google 、主机和域名)。 用户代理的优先顺序对于某个抓取工具而言 , | ||||||||||||||||||||||||||||||||||
| /* | 等同于 /。Bing 和其他主流搜索引擎支持有限形式的通配符。可将适用于多个用户代理的规则组合在一起
。抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时,如果下载的内容是 Html 格式而非 robots.txt 规则 , robots.txt 文件中列出的规则只适用于该文件所在的主机 、该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效 , | ||||||||||||||||||||||||||||||||||
| /fish* | 等同于 /fish。例如
, 同样 ,如果没有缓存副本 ,因此 Google 会暂时将服务器错误解读为网站完全禁止访问。 以下示例演示了 Google 抓取工具会对特定网址应用什么规则。 例如,端口号、所有抓取工具都可以追踪它们。并忽略超过该上限的内容 。
| ||||||||||||||||||||||||||||||||||
